Resolved
This incident has been resolved.
Monitoring
We have shipped a fix and we are seeing recovery of log data load times. We are continuing to monitor closely before resolving.
Investigating
We're seeing elevated response times loading some log data. This is leading to slower page loads in the Dashboard and slower responses from some V1 API endpoints.