Resolved
Tracking service event processing is no longer delayed.
Investigating
We are investigating delayed processing of tracking events. Message events associated with tracked-link clicks and email-open actions are delayed by a couple minutes currently for some customers. Tracked-link resolution is not affected.