Datadog Metrics Integration Delayed
Resolved

Datadog has recovered its services enough for us to re-enable this feature for all our customers.

Thu, Mar 9, 2023, 04:10 AM
(2 years ago)
·
Affected components

No components marked as affected

Updates

Resolved

Datadog has recovered its services enough for us to re-enable this feature for all our customers.

Thu, Mar 9, 2023, 04:10 AM

Monitoring

Our status page previously indicated that Knock was experiencing a major outage due to the Datadog outage. This was marked in error, as Knock has been operating as normal with the exception of forwarding metrics to Datadog for customers with that feature enabled. Metrics for Datadog are being buffered by Knock and will be forwarded as soon as Datadog's service is fully restored.

Wed, Mar 8, 2023, 07:16 PM(8 hours earlier)

Monitoring

Datadog has been reporting an outage at 1:31 AM ET. Although Knock continues to operate as normal, customers that use our Datadog integration may see that some metrics have been dropped during the outage. We began to buffer metrics internally at 1:03 PM ET to preserve those metrics, and to reduce pressure on Datadog’s API. Once Datadog’s incident is fully resolved, we will resume forwarding metrics to Datadog.

Wed, Mar 8, 2023, 06:30 PM(45 minutes earlier)