Major provider outage
Incident Report for Knock
Resolved
The underlying incident has now been resolved and all systems are operational again. This incident was caused by an outage in AWS us-east-2 AZ-1 losing power, which resulted in some of our critical systems failing. We failed over to other AZs where we could, restoring operational capability.

As a result of this incident however you may see:

1. Missing API logs from your dashboard for the period of 16:59 - 17:30 UTC
2. Missing workflow run logs for the period of 16:59 - 17:30 UTC
Posted Jul 28, 2022 - 18:06 UTC
Monitoring
All services within Knock are operational again. Some downstream providers may still be impacted by the outage in AWS us-east-2.

We're continuing to monitor.
Posted Jul 28, 2022 - 17:45 UTC
Update
There are ongoing issues with downstream providers, some notification deliverability may be impacted as a result.

Current Knock status:

- In-app feeds are operational
- Notification engine is processing normally
- Webhooks are processing normally
- Workflow run logs are delayed
- API logs are delayed
Posted Jul 28, 2022 - 17:35 UTC
Update
Our current status is:

- In-app feeds are partially degraded
- Notifications are still being sent
- API logs are not currently being processed
- Workflow run logs are currently not being processed
- Webhooks are current not being processed
Posted Jul 28, 2022 - 17:21 UTC
Investigating
We're having a major outage with our hosting provider. We're currently looking for ways to mitigate.
Posted Jul 28, 2022 - 17:08 UTC
This incident affected: Knock systems (Notification delivery, Dashboard, API).