Delayed message processing
Incident Report for Knock
Resolved
This incident has been resolved.
Posted May 26, 2022 - 23:02 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 26, 2022 - 19:48 UTC
Update
We have implemented a bypass on the affected component as we continue to investigate the root cause of this issue. All messages are currently processing in real-time with no delay, and there are no queued workflows to drain.
Posted May 26, 2022 - 19:47 UTC
Investigating
We've discovered that a subset of workflow triggers that were sent to Knock today from 2am UTC may have been delayed in being processed, leading to delayed notification generation.
Posted May 26, 2022 - 19:45 UTC
This incident affected: Knock systems (Notification delivery).