Degraded experience with workflow run logs and API logs
Resolved·Partial outage

We have corrected the issue and restored performance for the subset of workflow logs affected by this incident.

Tue, Aug 13, 2024, 11:46 PM
(8 months ago)
·
Affected components
Logs
Updates

Resolved

We have corrected the issue and restored performance for the subset of workflow logs affected by this incident.

Tue, Aug 13, 2024, 11:46 PM

Identified

We are applying a fix to restore access to affected workflow runs.

Tue, Aug 13, 2024, 09:56 PM(1 hour earlier)

Investigating

We are continuing to investigate issues loading workflow run details in the Knock Dashboard for a subset of our customers. API Logs and workflow run logs should still be vieable in the Dashboard. Recent workflow run logs should be available for all customers.

Tue, Aug 13, 2024, 09:11 PM(44 minutes earlier)

Investigating

We are continuing to investigate issues loading workflow run details in the Knock Dashboard for some customers. We will continue to provide updates as we make progress.

Tue, Aug 13, 2024, 07:45 PM(1 hour earlier)

Investigating

Impact here is so far isolated to viewing workflow run details in the Knock Dashboard. You should still be able to view API logs and the list of workflow run logs in the Dashboard.

We are still investigating the root issue.

Tue, Aug 13, 2024, 06:43 PM(1 hour earlier)

Investigating

We are investigating degraded performance of API and workflow logs in the Knock Dashboard. Logs are delayed or missing entirely for some customers. This issue is isolated to the Knock logging layer—all V1 API calls and notification delivery continue to run without issue.

Tue, Aug 13, 2024, 06:19 PM(23 minutes earlier)